Problems with running any 4k intro in my friend's laptop

category: general [glöplog]
Hey, yesterday I found a solution but I still don't know why it worked.

I opened a command line prompt from total commander and run the intros from there and it just worked. Then something even more strange happened, my friend came in, he told me to write cmd in total commander to open the command line (faster than me searching Run DOS in the menu),.. and it DIDN't work? So,. only if I choose the Run DOS in total commander (which actually still runs cmd.exe) it works. Even more crazy? For some reason,. it finds that path, only this way. Neither clicking on the exe in tcomannder (or even in windows explorer, because we thought we never use it and maybe tcommander could be the problem) only running Run DOS from the tc menu and not even running cmd.exe alone. Only then it works!

We have watched a bunch of cool 4ks yesteday, it's ok now, but can anyone guess why does this happen?
added on the 2008-07-10 08:52:01 by Optimus Optimus
reban optimus
optimus, several pointers/possibilities depending on your OS.
I'm not sure it is a laptop issue. Using cmd.exe launched from OS is not the same as using cmd.exe launched from another *.exe (has to do with environment vars and parent/child relationship of execv - on top of that there are related malloc failing issues too). You sould always try to cd to the directory before executing *.exe (or you can use a shortcut .pif/.lnk and specify execution directory explicitely), and if you are using xp or vista, you can force the compatibility to previous OS. There is a last issue with win32 dx prods that need a specific dx*.dll, and most of the time you can get that version on the net without conflicting with your original dx dll. There can be other issues too like needing access to extract.exe or c:\temp. Also, some intros use the "this program cannot run in Dos mode" stub to break out of non VM mode (in that case you need a shortcut to the .bat/.cmd itself). I guess every intro has its specific needs. The point is, once you get it working, you can gradually change an environment parameter iteratively, and see if it still works.
In a dos cmd prompt, look at theses commands : >set ?, start ?