So, how do you finally load ATR files in SIDE2?

category: general [glöplog]
I break my nerves with this. I never thought it would still be so hard to figure out. Lotharek promised me to show me at the party, but I didn't ask him to show me at the end, but I didn't want to bother him before and forgot to ask at the end of the party. Anyway, I thought I would finally manage to figure out alone at home. But no.

There are tons of documentation. Various forums I found. Describing all sort of weird stuff. Maybe I don't know the logic of this system yet.

So, one information I get is you can't just load FAT32 like this. You have to format or fdisk to partition the CF card somehow. You will get message FAT32 not found or PBI something not found. Also, I know now that pressing L in that special menu with Help+Reset, it will go to some loader specifically for ATR. But I get the message about FAT32 partition not existing.

Now, in some video, I see that a list of tools are there I think in the cart, like FDISK. And it's loaded from SpartanX OS. But if I boot on this OS, I get the mistake 138 device error. Are these tool files preloaded on the cart always?

I still don't understand the logic of how this works. My CF card is FAT32. And I reformatted it from Windows. Also, I found some single file version of fdisk.com in some forum, but fails with some random chars on screen.

A lot of people discuss on forums about how to load ATR, and all sort of random stuff, information and new problems arise. I never thought it would be so complicated. Help!
added on the 2014-12-10 01:20:10 by Optimonk Optimonk
So, one information I get is you can't just load FAT32 like this.

Errr ATR I mean..
added on the 2014-12-10 01:23:22 by Optimonk Optimonk
Have you seen already this document ? May be it would help you.

PS. You should have asked Lotharek, never the less. He is a cool dude, even if occupied it would have taken only few seconds.
Or as a random dude at the party ;).
added on the 2014-12-10 03:59:39 by sim sim
added on the 2014-12-10 04:02:43 by sim sim
Yeah, I have been reading these sites.

I think they only thing I have to do is succeed running this fdisk program. I found this bunch of tools but the irony, it's an ATR file again. Maybe if I could extract fdisk from the ATR. If I had fdisk as xex or com I could just follow the procedure and hopefully.


SIDE.SYS (driver)
FDISK.COM (disk partitioning tool)
HDDINFO.COM (hard disk information report utility)
PARTINFO.COM (partition information utility)
MOUNT.COM (dynamic partition mounting tool)

What confuses me is, are these supposed to be already loaded in the cartidge? Are they in some ROM in the cartidge?

Also, in this link I find some new stuff. Maybe what I want is SpartaX with APT tools. But what I see now is an ATR file (but that's my problem, I cannot load ATR file). Also there is a ROM file. Will try this when I go back at home. Is it a binary that I will click a run? Is it self boot? I hope I can work with this. The only XEX is Ultimate PBI bios 1.0, I think I am 1.0. But I could try reflash.

I feel like.
BB Image
added on the 2014-12-10 10:54:40 by Optimonk Optimonk
Wait. I will ask some of my fellows about, and will let you know here whether I got sth.
Meanwhile, I propose you to have a break (well, do what you want, thee know ;).
added on the 2014-12-10 13:53:48 by sim sim
Have you read this one and this ?

Keep me informed.

Thanx to Sheriff and AdamK for fast help.
added on the 2014-12-11 13:34:32 by sim sim
I gave a try it a bit.
I read again those links.

What I should is run the FDISK.
What most links say, this among other tools are already provided in the cartidge.
What I missed is that it's the CAR: device.

So when I start I am at D1: device, which I assume is disk1. Maybe my unpartitioned device? Maybe the missing disk drive in the other port?

But still. I thought I should write CAR: and find all tools. This does nothing and takes me back to D1:
You cannot make DIR to see. I get the same message, 138 device not present.

Then I tried reading the spartaxdos manual. I discovered that probably the dos is loaded in memory. Some commands work. But another misleading thing, if the command doesn't have correct arguments or at all, it gives you the 138 device not present message. Not any message like "command parameters missing".

So, I can now run some of the commands. There was a chkdsk :O /X which really shows me info about a ram disk. Ram disk, that could be useful, maybe there I could load an ATR?

But the info says to just run FDISK. FDISK doesn't work.
In the video on the above link. The guy is at D1: and just types FDISK without parameters. Also, in the manual of this dos, there is a list of all commands. FDISK is not there. It could be an external tool loaded through the disk port.

Actually, there is one way I could do it. Buy a SIO2SD. It also loads ATR and I think directly because it's in the tape/drive port. But then I solved the problem already, but not without the use of a third hardware. I might buy this one at some point, because I got this information that one of my favorite demos (Overmind) will not work on SIDE2 even if I manage to load ATR. But will work on any SIO hardware.

But is the FDISK really inside the cartidge? Is the CAR: device supposed to show me files? Maybe I should just take the ATR, search for a tool, extract the com/xex fdisk and run it? I will do that tomorrow maybe..

It is kinda Catch22
added on the 2014-12-12 00:20:58 by Optimonk Optimonk
So I extracted FDISK.XEX from the ATR.
I run it.
I follow tutorial in youtube.
For me, every option I choose (Open, Properties, Initialize) gives me back the message "No APT devices found"
I feel something is wrong. I just don't know what some of these things mean, what APT or PBI or other stuff is, why loading an ATR is so different than XEX, I don't even know if this means my device is malfunctioning or I am doing something wrong.
added on the 2014-12-12 01:31:16 by Optimonk Optimonk
It's driving me crazy.

First of all something else. I don't understand 100% when it goes to Loader, when it boots to DOS or just gets confused.

What I mean?
If I reset, it boots the DOS.
In order to go to the cart menu (where I load XEX), I had to switch off the Atari. And switch back on.
If I reset, it might go to DOS and not menu.
Anyway, there was some kind of weird logic, where to select in which of the menus to go, cart loader, or DOS boot, I had to do hard reset or soft reset accordingly.
It's so convoluted, but I was following a pattern to get what I want.

Now the crazy!
I managed to do some more. Get a XEX which updates PBI bios (which PBI I don't know what it refers to).
Something happened. Now when DOS boots I get additional line "Ultimate PBI V.1.0". So maybe it could be what was missing.

But now the crazy. I Cannot go to loader menu (so that I try to run the fdisk.xex again)
Now matter if I turn off and turn on that Atari. It always but always boots in DOS. Where I still cannot do something. I cannot DIR the files of the cart or something (then I would run FDISK from there).

Now, only if I try to reset while pressed little button on cartidge the loader comes up, but frozen without files!!!

Maybe I should post all these stuff in Atari forums and let people explain what is the logic behind anything. Needless to say, I still don't know if I am doing something wrong or my cart is defunkt.
added on the 2014-12-12 02:05:29 by Optimonk Optimonk
One more thing.

Ok, after this PBI update thing.
I can go to cart loader if I disable the SIDE hardware in setup (with Help+Reset)
But now if I go to dos, I don't see the message "Ultimate PBI V1.0".
But for me SIDE hardware == loader for XEX and whatever.
So, I disable SIDE in setup and now I get the loader?
Also, now I see this PBI has something to do with the SIDE hardware. But only if I enable it.

I was trying to have it boot to PBI message, then go to loader but it's again catch-22 because I can't do both at the same. No Side Hardware = XEX loader. Side Hardware = PBI but can't go into loader. And PBI loaded could be my solution, so that fdisk finds there is something to do something with.

I am driving you insane?
added on the 2014-12-12 02:24:53 by Optimonk Optimonk
WTF, I can't even read this all without getting a headache :( what are you trying to do?
With what/where/why?
is this a huge troll or are you actually needing help
added on the 2014-12-12 09:04:30 by BiasZ BiasZ

Definitelly not a troll.

But to explain all the parameters I need to write huge texts.
added on the 2014-12-12 09:26:59 by Optimonk Optimonk
can u link to the hardware/cart you are trying to get to work.
them be oldskool DOS commands, are you trying to get a SD card for a DOS machine to work or something?
added on the 2014-12-12 12:52:22 by BiasZ BiasZ

I asked with slightly less text here.

It starts making sense, even though it's chained: To run fdisk tools -> must update SDX ROM -> a XEX and a ROM file -> must update XEX loader if it's old (or maybe I am stuck).

Will try later at home.
added on the 2014-12-12 13:07:23 by Optimonk Optimonk
Oh atari, Never owned one of those :( , Just Sleep on it and it will come to you :) Good luck
added on the 2014-12-12 13:23:11 by BiasZ BiasZ
Btw, what's the different between this and this

One is almost three times more expensive, but it seems that the only difference is a solid box and the SIO cable for free. Which is just another 5 euros. I think if I buy any of these, my problems will go away. Oh god, I have already spend so much for Ataris :)
added on the 2014-12-12 14:03:35 by Optimonk Optimonk
I think your right, Just a fancy box and a cable it seems
added on the 2014-12-12 20:49:01 by BiasZ BiasZ
Optimus, some of my fellows I contacted had succeded in configurating the thingie. They indeed had some difficulties, but unfortunately they do not remember exactly what was that.
Have you contacted Lotharek? Do it, please.
added on the 2014-12-15 12:43:57 by sim sim
No, not yet. Will do. I was busy with other things, but will come back to the Atari soon.
added on the 2014-12-15 14:42:08 by Optimonk Optimonk
Also you can try AtariAge, there you'll find flashjazz cat who wrote much of the SIDE2, FDISK, APT software.
added on the 2014-12-15 19:15:29 by JAC! JAC!