webgl etherea2 feedbacks, please

category: general [glöplog]
Here is the demo: https://imersiva.com/demos/eo

Full source-code will be released in the next days. I just want to bug-fix and do some clean up before putting it on github.

- WebGL 2 support;
- WebVR support;
- Gamepad support;
- Real-time streaming to mobile (with head-tracking!) so you can see it in VR even on an average mobile and Google Cardboard;
- (soon) Persistent fractal editor for inserting your own 3D fractals in space.

I kindly ask for some feedback:

- Your Operating System (if you don't mind, also your GPU);
- Does it run for you?
- Do you see a few fractals floating in space, and you can visit/enter them?
(there is polygonal collision detection but as fractals won't collide yet, i disable that)
- Does the planet show complete, with spherical terrain?
- Does it run in 60fps?
- Any other comments, critics and/or suggestions?

Thank you.
added on the 2018-05-06 12:47:56 by imerso imerso
I will give a feedback myself:

- Ubuntu 16.04, AMD RX580;
- runs as expected;
- all fractals showing as expected;
- planet as expected;
- steady 60fps;

- Windows 10, AMD RX580;
- runs;
- all ractals;
- planet is just a sphere;
- 60fps.
added on the 2018-05-06 12:56:35 by imerso imerso
oh sheet, how i wish i could edit posts! would be good to know what browser you tried as well. thanks!
added on the 2018-05-06 12:57:32 by imerso imerso
That click for fullscreen is anoying as hell. Take it off.
added on the 2018-05-06 15:29:02 by xernobyl xernobyl
- Arch/Parabola/Gentoo frankenstein monster, Intel 2330M, GeForce 410M (nouveau drivers, mesa 17.3.7)
- tried with (rebranded) Firefox 59.0.2, (rebranded and slightly modified) Firefox 52.6.0, and Qutebrowser 1.2.1
- "no WebGL 2 detected on your hardware" (in Brazilian), on all browsers, even though it's enabled in about:config (or its equivalent in ~/.config/qutebrowser/qutebrowser.conf).

Also, is a video preview really needed? It's not very low-bandwidth friendly (or for people with download caps).
added on the 2018-05-06 15:29:07 by porocyon porocyon
having webgl2 enabled in the config doesn't necessarily mean your hardware(or driver) supports it
added on the 2018-05-06 15:34:36 by LJ LJ
That click for fullscreen is anoying as hell. Take it off.

Fullscreen on click was removed now. You might need to CTRL+F5 to fully refresh the page. I can't edit the first post, but here is the direct link:


having webgl2 enabled in the config doesn't necessarily mean your hardware(or driver) supports it

That is right. You can also check your hardware on http://webglreport.com/

added on the 2018-05-06 15:47:35 by imerso imerso
having webgl2 enabled in the config doesn't necessarily mean your hardware(or driver) supports it

That is right. You can also check your hardware on http://webglreport.com/

They're both supported (and it worked before). Mesa 17.3.7 is pretty much the latest (v18 was released a few days ago, haven't compiled it yet).
added on the 2018-05-06 15:53:51 by porocyon porocyon
Fullscreen on click was removed now.

If every support thing was as fast as you the world would be a better place.
added on the 2018-05-06 16:05:51 by xernobyl xernobyl
Just in case you still read this thread:

GeForce 410M (nouveau drivers, mesa 17.3.7)

Did http://webglreport.com/ report WebGL2 support? That would be really strange, but please let me know.

Anyway, some demos out there will fall back to WebGL1 if WebGL2 support fails (in their case, they don't really *need* the wgl2 extra features). This demo here won't fall back, it will simply refuse to run, because it *does* need the extra features.

"no WebGL 2 detected on your hardware"

That result is from a single line which tries to get a WebGL2 context. If that fails, well, I would be 99% confident that your system is currently not WebGL2 capable -- not saying that your *hardware* is not capable, but the system (driver or something else) is most probably not.

You could maybe dual boot into Windows and check that with Windows drivers.

Thank you for the feedback!
added on the 2018-05-07 10:40:12 by imerso imerso
Win10, Chrome, GTX 1060; I get cockpit + legend in the top left counting FPS (~120ish in 1080p) but nothing moves and I can't seem to control anything.
added on the 2018-05-07 10:49:38 by Gargaj Gargaj
Did you click inside the window? =)
added on the 2018-05-07 10:53:04 by imerso imerso
Yes. No change, and as I said, nothing is moving, there's no animation, nothing.
added on the 2018-05-07 10:54:16 by Gargaj Gargaj
Think this might be the reason:
Code:_-game-_.t:676 Uncaught TypeError: Cannot read property 'value' of undefined at Control_Gamepad.afkg_hs (_-game-_.t:676) at InputControl.afkg_hsControls (_-game-_.t:690) at afkg_hs (_-game-_.t:723)
added on the 2018-05-07 10:55:09 by Gargaj Gargaj
Oh, that is weird. If you have an extra minute, please CTRL+SHIFT+J (open console) then see if there is any error there?

added on the 2018-05-07 10:55:45 by imerso imerso
(Posted before seeing)

Oh, you have a plugged gamepad? There is some time I don't test gamepads, will test right now, might be broken that!
added on the 2018-05-07 10:56:45 by imerso imerso
I didn't, now I plugged in the Xbox One pad I have and it's still the same problem.
added on the 2018-05-07 10:57:15 by Gargaj Gargaj
Any VR device (Oculus Rift with Touch for ex)? Something might be wrongly detected as gamepad.

Asking just so I can pinpoint the bug, thank you very much.
added on the 2018-05-07 10:58:43 by imerso imerso
I do have a Rift plugged on, yes.
added on the 2018-05-07 10:59:08 by Gargaj Gargaj
And a Steam Controller.
added on the 2018-05-07 10:59:31 by Gargaj Gargaj
Oh and a driving wheel.
added on the 2018-05-07 10:59:44 by Gargaj Gargaj
That is it. I should disable Gamepad then for now, will upload in a few minutes. Thanks for the help!
added on the 2018-05-07 11:01:33 by imerso imerso
It looks like it's the wheel because you assume it has a lot more buttons than it actually has :)

BB Image
added on the 2018-05-07 11:02:41 by Gargaj Gargaj
Note: I just uploaded a version with Gamepad support disabled for now.

Gargaj: you are very right on this. As you probably know, the problem with usb controllers (gamepads, wheels etc) is that there is no standard, so the only way to really know them is by letting the user configure buttons (pressing and moving).

I confess I was naive on gamepad support, just assuming that people will be using a XBox controller or similar, and no wheels / touch etc. Then I forgot about that. =)
added on the 2018-05-07 11:19:41 by imerso imerso
Okay now it seems to work fine except I can't seem to INCREASE ([) the FOV, only decrease it (]).
added on the 2018-05-07 11:22:48 by Gargaj Gargaj