pouët.net

Rotor by Titan [web]
[nfo]
screenshot added by EviL on 2005-05-27 17:29:24
platform :
type :
release date : may 2005
  • rulez 24
  • is ok 17
  • sucks 6
popularity : 0%
 0%
  • rulez 0.38
alltime top: #4626
added on the 2005-05-27 17:23:50 by iks iks

popularity helper

increase the popularity of this prod by spreading this URL:

or via: facebook twitter google+ pinterest tumblr

comments

screenshot impossible, sorry.
added on the 2005-05-27 17:24:13 by iks iks
kewl
rulez added on the 2005-05-27 17:29:11 by aLpHa oNe aLpHa oNe
nice... and screenshot possible yes :D
rulez added on the 2005-05-27 17:29:54 by EviL EviL
makes me dizzy
added on the 2005-05-27 17:30:20 by ogge_ ogge_
music rockz hard!
rulez added on the 2005-05-27 17:31:49 by Lupin Lupin
Nice one ! :)
rulez added on the 2005-05-27 17:39:40 by kohai kohai
wahat about a full demo / intro one day ?
nice one
rulez added on the 2005-05-27 17:44:51 by nytrik nytrik
R.O.T.O.R ROBOTIC OFFICER TACTICAL OPERATION RESEARCH !!!!111 http://finnish.imdb.com/title/tt0098156/
rulez added on the 2005-05-27 17:51:59 by uns3en_ uns3en_
What a delight to eyes and ears
added on the 2005-05-27 17:52:53 by Preacher Preacher
cool.
rulez added on the 2005-05-27 17:55:09 by got got
music + effect? 1kb?
rulez added on the 2005-05-27 18:14:41 by imbusy imbusy
only the 4,5 kb runs here. the other one crashes after showing a black screen with those "stars".
really nice for the fact that it has "music", but yeah, the effect is kinda simple (some rotating layers \o/), no textures or such.

you could increase the qualitiy by doing that without render to texture and using glLineWidth instead
added on the 2005-05-27 18:33:57 by las las
rulez added on the 2005-05-27 18:37:58 by Quarryman Quarryman
!vitsipirkka rotor
added on the 2005-05-27 18:54:10 by break break
Titan of 1k
rulez added on the 2005-05-27 18:57:14 by blueflame blueflame
SIZE!!!
rulez added on the 2005-05-27 20:07:37 by alien^PDX alien^PDX
i don't hear any sound.. effect is quite ok for a windows 1k i guess.
added on the 2005-05-27 21:10:07 by annieeee annieeee
roxx definatly
rulez added on the 2005-05-27 21:49:57 by _docd _docd
:o
which music ?
those 6 sounds! :)
added on the 2005-05-28 00:07:45 by Maali Maali
sorry but this is too cheap for 1k
sucks added on the 2005-05-28 12:24:13 by PigPen PigPen
Heheh . cool :)
added on the 2005-05-28 14:12:21 by loaderror loaderror
Quite simple effect but still only 1k. Would have done better without the sound since the beat is i very jerky. In total---OK.
added on the 2005-05-28 16:22:25 by ManJIT ManJIT
great for 1k ! one of the rare 1k i saw with sound, if not the only one ! u guys made a really nice work !
rulez added on the 2005-05-28 17:18:13 by bull bull
nice with the sfx
rulez added on the 2005-05-28 19:07:29 by NuKem NuKem
Doesn't work on my xp pro sp2
added on the 2005-05-28 21:48:04 by rio702 rio702
haha shid dudes :D
rulez added on the 2005-05-28 22:01:41 by fup fup
sucks added on the 2005-05-29 13:30:09 by Shifter Shifter
hahaha nice =)
rulez added on the 2005-05-29 21:20:42 by red red
Codewise ok, but it doesn't look cool.
added on the 2005-06-03 20:13:23 by jimmi jimmi
Nice work guys !
rulez added on the 2005-06-22 10:02:19 by DrSKULL DrSKULL
It's ok, but something's missing. I'm not expecting a tremendous effect for a 1K w/ "music", but this one's really weak.
added on the 2005-06-24 04:44:55 by knox knox
rox for 1K
rulez added on the 2005-07-18 18:16:16 by ken0 ken0
1k version doesnt run, displays first frame, then crashes.
3k version runs but no music.
added on the 2005-09-16 00:22:22 by Gargaj Gargaj
gargaj, what os, hardware do you got?
Servicepacks etc would be helpfull to. its hard to make this small things work for everybody, but ofcourse thats the goal...
anyone else got bugs to? please share them :)
added on the 2005-09-16 01:01:02 by saida saida
1k: doesn't run, displays not even the first frame
3k: runs but without sound
WinXP SP1, Radeon 9600
saida: 1.2ghz + 384mb ram + r9800pro with latest drivers + winxp

callstack:
NTDLL! 77f7f5fa()
MZ! 004012dd()
added on the 2005-09-16 01:16:16 by Gargaj Gargaj
runs smooth on p4 3,4 2GB x800 pro....
rulez added on the 2005-09-16 01:25:07 by 4kum4 4kum4
did some further debugging and what i seemingly noticed is that i dunno which execruncher do you use but it seriously seems to fuck up the exe (wrong ordinal imports - GetTickCount became GetVolumePathNamesForVolumeName)
added on the 2005-09-16 02:48:52 by Gargaj Gargaj
i might wanna add is that GetVolumePathNamesForVolumeName is an XP only function so that might be the problem.
added on the 2005-09-16 02:51:14 by Gargaj Gargaj
You are talking about the safe exe, right?
That exe is nothing but an standard masm32 exe, so no cruncher is used... so imports should be fine? cant figure out where the problem is.
You said you done some debugging and found out that GetVolumePathNamesForVolumeName was called instead of GetTickCount? - try open the exe with W32Dasm or something and check what you got.
Anyway, since the GetVolumePathNamesForVolumeName function will use four dwords from a stack where "nothing" have been pushed, it will drain the stack very quick and crash the program by feeding it with invalid pointers or something...
- gargaj:
open the exe in a hexeditor or something... search for the string "GetTickCount" -> how does your compouter convert that to another function "GetVolumePathNamesForVolumeName " seems like a weird thing to do :) check your computer for virus, hehe.
added on the 2005-09-16 12:25:34 by saida saida
of COURSE, i'm talking about the packed exe. I said the safe exe runs without a hitch.
you're using ordinal imports to crunch the exe, there are no function names in that one, i just used the disassemblies to compare the two - and whats GetTickCount in the safe one is GetVolumePathNamesForVolumeName in the crunched one.

i repeat: your execruncher might be screwed.
added on the 2005-09-16 12:40:47 by Gargaj Gargaj
yea, i think we used apack or dropper or something like that in this one, so thats what scewing it up... thats why the com doesnt run on all machines i guess.
added on the 2005-09-16 13:07:16 by saida saida
i still dont have sound in either though :)
added on the 2005-09-16 13:36:25 by Gargaj Gargaj
check your midi settings in the controllpanel :)
And try changing default midiOut device and turn up your midi volume :P
If that doesnt work, i have no idea, hehe...
added on the 2005-09-16 16:42:26 by saida saida
ah
rulez added on the 2005-10-27 11:55:40 by iks iks
Nice effect, but only the save version runs here.
Isn't working on WinXP SP2
sucks added on the 2005-11-13 13:50:09 by Midfit Midfit
is it a reason to thumb it down? Midfit, you suck major dicks for sure.
added on the 2005-11-14 13:15:12 by iks iks
i got xp sp2 and it works fine.

upgrade your drivers midfit.
added on the 2005-11-16 08:26:16 by bull bull
rulez added on the 2005-11-16 09:59:50 by Cj Cj
sorry other titan members, but some of your stupid members flooded with their accounts and clones on kstorm prods, and after on kstorm website saying "if you dont stop thumb down our prods on pouet we'll always flood you". So, here goes my thumb down to these members. Last ones were objective, you are not so now i'm not.
sucks added on the 2005-11-17 21:37:01 by skarab skarab
stop flooding!
sucks added on the 2005-11-17 21:48:31 by nugua nugua
rulez added on the 2005-12-11 16:45:04 by [ej] [ej]
slow as hell
added on the 2005-12-15 04:01:24 by dila dila
Motion sickness! I got twisted!
rulez added on the 2007-08-09 12:31:39 by TOMPCpl TOMPCpl
my only problem is with music is, it doesn't leave enough space for enjoyable graphics.
rulez added on the 2008-02-27 13:15:35 by pohar pohar
Wrong ordinal imports.
sucks added on the 2008-06-12 20:17:31 by rale rale

submit changes

if this prod is a fake, some info is false or the download link is broken,

do not post about it in the comments, it will get lost.

instead, click here !

[previous edits]

add a comment