Oric stuffs

category: offtopic [glöplog]
0.9 is out now for Windows and AmigaOS 4.x. I don't maintain the other ports, so I dunno when they'll be updated.

This is quite an exciting update, because for Oric-1 and Atmos emulation, it has reached a point where it is a comprehensive alternative to the previous defacto-standard in Oric emulation (Euphoric), and in quite a lot of ways is actually better.
added on the 2012-03-03 13:43:12 by xeron xeron
Well congrats on this work! :)
added on the 2012-03-04 18:33:34 by baah baah
1.0 is out now for Windows and AmigaOS 4.x. Hopefully others will follow soon.

This release includes Pravetz 8D disk support, and working telestrat emulation.
added on the 2013-10-22 23:08:48 by xeron xeron
When I try to run the 1.0 for win32 I get this:
"The program can't start because libgcc_s_dw2-1.dll is missing from your computer".
added on the 2013-10-22 23:39:58 by Sdw Sdw
Hmmm.. nobody has reported this bug before :-( it is compiled with mingw32-gcc. It runs OK on my Win7 laptop...
added on the 2013-10-22 23:43:46 by xeron xeron
OK, refresh the bintray site. The windows download should now say "(recompiled)" in the description. Download it and try again.
added on the 2013-10-22 23:53:36 by xeron xeron
Recompiled version works fine!
added on the 2013-10-23 10:19:05 by Sdw Sdw
Excellent! Kick ass emulator.
I tried the amazing ported games I read from this thread, on a netbook. Stormlord and Impossible Mission. Holy crap, awesome too.
1.1 is out now for Windows. Amiga OS 4.x will arrive in the next day or so. Hopefully others will also follow soon.
added on the 2013-12-08 01:13:01 by xeron xeron
OS4 build is up :)
added on the 2013-12-08 13:54:54 by xeron xeron
1.2 is out now for windows and OS4 others will probably follow soon.

Change log.
added on the 2014-11-02 10:44:48 by xeron xeron
The OSX WIP binary seems to be restricted to 10.9 only? Would be nice if it supported some previous versions (I'm running 10.8.4.)

I tried building it from source (using 'make' from the command line, not xcode) - it compiles fine but when I run it I get this error:

Code:quaoar:Oricutron_src $ oricutron Unable to open 'roms/microdis.rom' Unable to open 'roms/jasmin.rom' Unable to open 'roms/8dos.rom' Unable to open 'images/statusbar.bmp'

Suggestions on how to get it running?
added on the 2014-11-02 11:21:03 by jmph jmph
Suggestions on how to get it running?

try to add ROM binaries?

how to create .tap-file with binary?
added on the 2014-11-02 11:24:17 by g0blinish g0blinish

I don't maintain the mac build i'm afraid. Maybe try asking on the defence force forum?
added on the 2014-11-02 12:06:53 by xeron xeron

I had a thought. There is code at startup that specifically enables the mac build to find all the roms etc. I wonder if the makefile doesn't set some options that get set when you compile using the xcode stuff that is in the repo?
added on the 2014-11-03 07:14:40 by xeron xeron