Getting random resets when running demos

category: general [glöplog]
Just recently, I've noticed several demos cause an instant reset when I try to run them.

Pc details - Windows 7, geforce gtx760, intel i5, 8g ram, motherboard is gigabyte h87n-wifi, no overclocking its just over 3 years old.

a few of the demos causing crashes are one's which I've previously run on this pc with no problems. (1 eg - revision 2013 - 4k compo - "ride to the mysteriuous cities"), kohlenstoffenheit also crashes, as do several intros from revision 2012, most of which I've never ran on this pc before.

I guess I've found about 30 demos which do this.

Crash details - in about 90% of the demos which cause this, the reset happens pretty much as soon as the demo starts running (or at most within a few seconds) - occasionally, if I select a lower resolution, or windowed mode (if available) it may run for longer, or in one or 2 examples, I can see the full demo.

This s where it's a bit odd - when it happens the PC just resets - no BSOD, no warning, just *BLAM*. There are also no minidump files looking at the event viewer, first sign of the problem is a "critical" listing for kernel-power, "The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.", sometimes I get another error saying "shutdown was unexpected"

I also get the following errors (although I'm not sure which are connected):
- Session "Microsoft Security Client OOBE" stopped due to the following error: 0xC000000D
- Audit events have been dropped by the transport. 0

So any clues as to what may be happening - I could give some more demo names if that might help? or any ideas how I might troubleshoot without any helpful BSOD or minidump?

I've ran HWmonitor - and nothing seems out of range temperature wise (maximum of any is 51 or 52 degrees)

Many thanks if anyone can help!
Could be either a dying power supply (too much voltage fluctuation when the system is under pressure) or a dying motherboard.
added on the 2017-04-24 00:17:54 by Gargaj Gargaj
I lied - "ride to the mysteriuous cities" runs fine, "the city"£ from the same compo doesn't!
Motherboard problem could be the case - When I was pc shopping, as few people mentioned that gigabytes can have power issues! (then again, whatever product you get there are usually a few bad comments!)
i would check memory with memtest86 first. bad memory can cause all sorts of weird spooky shit.
added on the 2017-04-24 01:03:45 by groepaz groepaz
Folks, a general question but defo related to this topic of prod crashes - can you please advise?

After moving from Win7 to Win10 loads of prods stopped working for me. If it because of Win10 or the new Nvidia drivers?

What setup therefore would you recommend to be able to run anything what was running well on W7, without actually migrating back to Win7? I would like to stay on Win10 (especially that I'm planning to buy Ryzen which is not compliant with the old Win). What is be the best solution? Is there any free VM with 3d acceleration which can be used as Win7 ultimate demo machine?

Tks for all your comments.
added on the 2017-04-24 01:13:49 by pouetmk pouetmk
What specific prods stopped working?
added on the 2017-04-24 01:52:33 by Gargaj Gargaj
caffeine_demon: could be lots of things, memory, power supply. gfxcard coming to the end of it's life cycle, motherboard. definitely hardware though.

pouetmk: pretty much all prods should still work from win7 to win10, check this other thread about win10 demos.
added on the 2017-04-24 02:19:15 by psenough psenough
Memtest came up clear.

another possible clue - sometimes the pc doesn't wake out of sleep mode properly - I press the mouse button, the keyboard lights up, pc unit lights up, mouse lights up - but the monitor doesn't turn on properly - think it points to motherboard or PSU...
Sounds like psu. Had the same issue when building my gaming rig, replaced that and everything was fine after. Maybe borrow one from someone one as a test first though.
added on the 2017-04-24 11:09:05 by djh0ffman djh0ffman
interesting - I tried one of the demos which crashes on my system, on a vmware box running xp - and it worked ok! (maybe the vmware GPU support uses the cpu instead?)

anyway - it's looking like psu, gpu or mobo.

Just got a PSU tester - is that likely to tell me if the psu might be unstable?
couple more findings (sorry to bore you):
1 - things seem to work ok using the internal graphics (albeit slowly in HD mode)

2 - PSU voltages:

-12v = 11.4 (i'm guessing thats -)
12v1 and 2 = 11.7
+5v = 4.9 and 5 (forgot which way round)
+3.3v = 3.3

do those look good?
Every time you don´t use your GPU you seem to be fine.
So either this is the GPU itself...or just the driver.

So you should install an older driver...maybe even go back more than one version...and test again.
If all is fine then it´s the current driver that´s causing these issues.
If it´s still not running as before try to insert an other graphics card and retest.

I had a problem with an NVidia-driver (about two versions ago) ... some googling revealed the 3DVision-Driver was bugged and causing my issues...so i simply uninstalled that (and left the Driver itself installed) and it worked as intended again! I don´t have any 3D-Devices anyway, so this was a nobrainer.

It could aswell be the PSU...not giving enough power to the GPU anymore (which could also be a byproduct of a newer driver, which causes more power-needs). Would describe everything being fine without usage of the GPU aswell.
Make sure your 4-pin or 6-pin-connectors are connected properly first.
Exchanging the PSU is a good idea to test that...just lend one from a friend if you dont have one which provides the same or more power lying around.

The "not coming back from sleep-mode"-problem occured to me quite often with my old rig...i figured (after some months) it happened when i kept moving_my_mouse/hitting_keys after initiating sleep-mode. So once i watched out not to do anything of that anymore once i clicked the SLEEP-Button it stopped.

Generally i guess with such sort of problems you are better off visiting pages dedicated to hardware-problems, though! ;) Often there´s even already a solution posted to the problem you ran into...happened quite often to me. (tomshardware and such)
Addition about PSU: of course make sure it provides enough power for all your components.
Even adding an additional Harddrive may use up an amount of power your GPU will miss when needed then.
So if you also put extra-stuff into your PC the last months, try to remove it and see if it works as before. ;)
Don´t forget that lots of stuff sucks power via USB! ;) So all your USB-Connections could be stealing power from the GPU aswell. To test that you should simply unplug all USB-Devices, except your mouse and keyboard of course, and retest some prods.
Another possible issue is overheating. You should be able to rule that out by seeing what sort of temperatures are getting reported. In this case, it'd probably be your GPU that's overheating. Something electrical with the GPU or PSU is also very likely too.
added on the 2017-04-27 10:12:22 by FreeFull FreeFull
Over a dozen comments before somebody said overheating? Dude it's overheating, hoover it!
added on the 2017-04-27 10:29:29 by Fell Fell
vacuum (unless its really a hoover) :)

although there is advice out there saying don't vacuum (due to static) live life on the edge :)
added on the 2017-04-27 10:38:01 by Canopy Canopy
genericised marks are idiomatically valid :P
added on the 2017-04-27 13:52:02 by Fell Fell
What specific prods stopped working?

I may actually try and build a list as there is a number of them. Every now and then I watch demos for hours to relax. With Win7 all worked well, while on win10 I have noticed that a number just didn't (black screen and that's it). To name a few Cocoon is impacted and many 4k prods. When I have time I may supply a list but glad to hear there should be no issues - I may just to reinstall. Tks!
added on the 2017-05-01 22:47:00 by pouetmk pouetmk
interesting - I tried one of the demos which crashes on my system, on a vmware box running xp - and it worked ok! (maybe the vmware GPU support uses the cpu instead?)

anyway - it's looking like psu, gpu or mobo.

Just got a PSU tester - is that likely to tell me if the psu might be unstable?

What particular VM build do you use? Does it support DX and GPU acceleration? What is the difference between the real hardware and VM performance-wise? Tks.
added on the 2017-05-01 22:49:19 by pouetmk pouetmk
With 4ks it may help to redownload the latest version or manually recompress them using Crinkler.
Thanks for the tips, unfortunately none of them seem to work so far :(

So - I think I'm going to take it to a repair shop, thinking if it's the PSU or Gfx card, I'll swap that, but if it's the mobo, i'll grin and bear it for a while.

Maybe I'll also consider dual booting with windows 8.1 or 10 for a while.
saga: yes, but an old crinkler with new driver combo usually crash just the intro, not the whole machine
added on the 2017-05-04 02:21:11 by T$ T$